Главная > MikroTik > Mikrotik и IPTV

Mikrotik и IPTV

10 097

Провайдер вещает мультикастом IPTV, задача - пробросить в сеть за микротиком услугу, чтобы можно было смотреть HD IPTV на ноуте, планшете или Smart TV.

260

mikrotik rb951g-2hnd

Дано: mikrotik RouterBOARD 951G-2HnD (v6.12). Ставим пакет multicast, если он еще не стоит. Скачать можно тут: http://download2.mikrotik.com/routeros/6.12/all_packages-mipsbe-6.12.zip

Настройка пакета выглядит следующим образом:

Идем в  Routing->IGMP Proxy

multicast

Где:

HOME-LAN - это Bridge домашней сети, в которой все порты и WI-FI, кроме WAN-порта

ether5- физический порт, на который приходит мультикаст от провайдера.

Пробуем проиграть плейлист IPTV.. Видим что пакеты побежали.. Все ок, в том числе и при проигрывании через Wi-FI.

P.S. Но есть одно НО:

Заметил, что в такой реализации мы получаем мультикаст трафик на все порты в бридже, в том числе и  на WI-FI. Это может показаться неприемлемым, потому как наблюдается падение скорости на интерфейсах, особенно на WI-FI. Поэтому давайте запретим мультикаст трафик везде на бридже кроме одного эзернета из этого бриджа:

Задаем порту эзернет, на котором висит SMART TV или приставка ваша, IP адрес из вашей домашней сети, а потом-

/interface bridge filter add chain=output out-interface=!ether3 action=drop mac-protocol=ip packet-type=multicast

где ether3 - порт, на коротом у меня SMART TV

Categories: MikroTik Tags: ,
  1. Ремир
    25 июля 2017 в 09:14 | #1

    Добрый день, я конечно понимаю что прошло много времени, но. Делаю все как с мануале, пытаюсь закрыть мультикаст на всех портах кроме 4. Ставлю ! знак на ether4 перестает работать IPTV, убираю работает. Но как я понимаю фильтр при этом не работает(

  2. Родомир
    23 февраля 2016 в 00:16 | #2

    @srv
    вы имеете ввиду программное разделение(настройками)?

  3. Родомир
    22 февраля 2016 в 22:08 | #4

    Вопрос такого плана на роутер RouterBoard RB951G-2HnD приходит итернет и IPTV . далее с одного порта роутера сигнал идет на свич, там и раздается на комп(интернет) и прставку IPTV . как только включается приставка и идут передачи IPTV , wi-fi не просто затыкается , а затыкаетсяна уровне присвоения ip-адреса. Если каккие мысли как с этим бороться?

    • 22 февраля 2016 в 23:20 | #5

      А вы сделали как в статье? Разделили мультикаст интерфейс с остальными интерфейсами ?

  4. Анатолий
    3 января 2016 в 00:58 | #6

    Вопрос решен, дело было в моей не внимательности, порт был не в бридже, а в мастер-порте.
    Перенес в бридж и все заработало.

  5. Анатолий
    31 декабря 2015 в 20:27 | #7

    У меня какая-то ерунда получается с блокировкой.
    Мне нужно правда заблокировать определенный интерфейс, а не все кроме одного,
    но я думаю суть особо не меняется, вот:

    1) Если блокирую свой комп (интерфейс), то на компе уже ничего просмотреть не могу.
    Т.е. теоретически все работает.

    [admin@MT] > /interface bridge filter print
    Flags: X — disabled, I — invalid, D — dynamic
    0 chain=output action=drop out-interface=LAN2-MyComp mac-protocol=ip
    packet-type=multicast log=no log-prefix=»»

    2) Если блокирую все интерфейсы, кроме одного, то на них все равно идет трафик.

    [admin@MT] > /interface bridge filter print
    Flags: X — disabled, I — invalid, D — dynamic
    0 chain=output action=drop out-interface=!LAN2-MyComp mac-protocol=ip
    packet-type=multicast log=no log-prefix=»»

  6. boroda
    24 июля 2015 в 23:56 | #8

    если я все правильно понял то необходимо в IP->Addresses локальному ip соответствующему лан-гетвею выставить интерфейс bridge1(мой лан бридж). Надеюсь у вас опечатка и вы имели в виду 192.168.1.1 а не 192.168.0.1.

    и еще вопрос, разве результатом команды
    /interface bridge filter add chain=output out-interface=!ether3 action=DROP mac-protocol=ip packet-type=multicast
    не является именно запрет мультикаста на ether3, что является абсолютной противоположностью поставленной задачи, оставить мультикаст именно на этом порту?

    • 25 июля 2015 в 00:23 | #9

      Да, конечно опечатка . да, выставить ip вашего микротика бриджу. По поводу фильтра- восклицателтный знак это знак отрицания. То есть дропать везде, кроме 3его порта

  7. 24 июля 2015 в 12:44 | #10

    @boroda
    именно так сделано, чтобы иметь возможность того, чтобы ваш телевизор видел и домашнюю сеть, и IP-TV одновременно. В противном случае можно было бы не применять фильтр, но и не заводить эзернет с телевизором в бридж домашней сети

  8. 24 июля 2015 в 12:40 | #11

    @boroda
    имеется в виду,что задаем интерфейсу bridge (ваш bridge домашней сети) ip адрес.
    Т.е, если ваша конфигурация типовая для дома (это когда wifi, и порты ethernet объединены в один bridge), то у вашего бриджа должен быть адрес вашей домашней сети (например сеть дома 192.168.1.0/24, то как правило шлюзом для них является этот микротик, т.е адрес у него, например, должен быть (опять же, к примеру) 192.168.0.1. И адрес этот должен принадлежать интерфейсу bridge).
    А фильтр, который вы применяете для мультикаста, рубит на бридже этот самый мультикаст на всех интерфейсах, включенных в бридж,кроме того эзернет порта, в который воткнут ваш телевизор.

  9. boroda
    24 июля 2015 в 12:27 | #12

    если не сложно расшифруйте фразу «Задаем порту эзернет, на котором висит SMART TV или приставка ваша, IP адрес из вашей домашней сети» . даем статику устройству или просто в IP-Addresses на интерфейс вешаем IP. Если не сложно то опишите последовательность действий.

  10. 17 мая 2014 в 13:40 | #13

    @Roman
    нет, дропать в моем случае все равно нужно, потому как мультикаст я пробрасываю на бридж, как я написал. А в бридже у меня все эзернеты+WIFI кроме WAN. FULL multicast helper рекомендуется включать на wifi для нормального просмотра именно в беспроводной сети и он у меня был включен, конечно же. Но в моем случае проблема былла имеено в том, что мультикаст при проигрывании на телеке появлялся на КАЖДОМ интерфейсе, включенном в бридж.

  11. Roman
    14 мая 2014 в 15:30 | #14

    Не забываем ставить Multicsat Helper: FULL и дропить не потребуется.

  1. Пока что нет уведомлений.

.